Wordpress Fehler
Wordpress Fehler

Hier findet dein die Antworten auf die häufigsten WordPress Fehler!

du willst nur kurz etwas an deiner Website erstellen lassen, aber stoßen auf ein technisches Problem. Das kann sehr verärgernd sein und den Tag zu einer anstrengenden Aufgabe machen. Um das zu vermeiden, haben wir zehn typische WordPress Fehler zusammen mit deren Lösungen zusammengestellt.

Diese zehn WordPress Fehler sind diejenigen, die am häufigsten in unserem Mitgliederbereich angesprochen werden und wir fanden bisher immer eine Lösung.

Ein kurzer Tipp vorweg: Fast jedes Problem kann man im schlimmsten Fall immer mit dem Einspielen eines WordPress-Backups beheben; stellen du unbedingt automatische Backups ein! In den meisten Fällen wird vonseiten des Webhosting ein tägliches Update all deiner Dateien gemacht.

Es gab einen kritischen Fehler auf deiner Webseite

Was kann die Ursache sein, wenn eine Verbindung zur Datenbank nicht aufgebaut werden kann, was dazu führt, dass die Website nicht mehr erreichbar ist?

Dies tritt häufig auf, wenn du WordPress installieren, um deine Website zu erstellen. Wie kann man dies beheben? In der Regel liegt es an fehlerhaften Zugangsdaten der Datenbank.

Diese finden du in der wp-config.php Datei, die sich im Hauptordner deiner WordPress Installation befindet. Überprüfen du hier die folgenden Daten:

  • Datenbankhost
  • Datenbankname
  • Benutzername und Passwort

Dies können du tun, indem du sich bei deinem Hoster anmelden und auf die Datenbankübersicht zugreifen. Hier finden du die Zugangsdaten, die du vergleichen können. Alternativ können du sich auch mit den Daten aus der wp-config.php Datei in die Datenbank per PhpMyAdmin einloggen.

Fehler beim Aufbau einer Datenbankverbindung

Was ist das?

Unter Umständen liegt ein WordPress Fehler vor, der durch ein fehlerhaftes Plugin oder Theme entsteht. Der WordPress Fehler wird in der Regel durch eine Fehlermeldung darauf aufmerksam machen und uns so mitteilen, wo wir suchen müssen.

Wie kann man den WordPress Fehler beheben?

Um herauszufinden, welche Ursache der kritische WordPress Fehler hat, wird dir ein WordPress Fehler bzw. Benachrichtigung zukommen lassen, welche dir Aufschluss über das betroffene Plugin oder Theme gibt. Anschließend können du die betroffenen Ordner per FTP umbenennen, um es zu deaktivieren.

Sollte keine Fehlermeldung eintreffen oder du nicht weiterhelfen, müssen du die Plugins nacheinander deaktivieren, indem du die entsprechenden Pluginordner (/wp-content/plugins) umbenennen.

Falls das auch keine Lösung bietet, liegt wahrscheinlich ein Problem mit deinem Theme vor. Wir empfehlen dir daher, über FTP den Ordner des Themes (/wp-content/themes) umzubenennen, womit dieses deaktiviert wird.

ERR_TOO_MANY_REDIRECTSEs – zu viele Weiterleitungen

Was ist das “too many redirects” Problem?

Oft tritt es auf, nachdem ein Domain- oder Hosterumzug, einer Umstellung von HTTP auf HTTPS oder durch Fehler ausgehender von Plugins erfolgt ist. Dadurch kann es sein, dass man sich nicht mehr einloggen kann, oder aber die WordPress Webseite allgemein nicht erreichbar ist.

Wie kann man das Problem beheben?

Da es diverse Ursachen haben kann, ist es meist eine Frage des Ausprobierens. Falls du einen Domain- oder Hosterumzug vorgenommen haben, sollten du zunächst bei den Datenbankpfaden und der WordPress- und Websiteadresse ansetzen.

Nutze ein Plugin zur Anpassung des Logins, könnte dies ebenfalls die Quelle sein. Um das Problem zu lösen, empfiehlt es sich, zunächst einen Reload zu erzwingen und anschließend den Browser-Cache, den Server-Cache und die Cookies zu löschen.

White Screen of Death – Wenn WordPress eine weiße Seite anzeigt

Hast du schon mal von dem sogenannten White Screen of Death gehört?

Dieser tritt bei jedem WordPress-Blogger einmal auf. Wenn du deinen Blog aufrufen, wird dein ganzer Bildschirm plötzlich weiß und ein WordPress Fehler gibt dir eine leere Seite anzeigen. du denken vielleicht „Alles ist verschwunden“, aber in Wirklichkeit ist alles noch da.

Wie können du den Fehler beheben?

Es können mehrere Ursachen für diesen WordPress Fehler existieren und für jede gibt es eine Lösung. Eine häufige Ursache ist zu geringes oder fehlendes PHP Memory Limit. Um den White Screen of Death zu beheben, müssen du per FTP-Programm zu der wp-config.php im Hauptordner deiner WordPress-Installation navigieren, sie öffnen und die folgende Zeile einfügen. Achte darauf darauf, dass du die Zeile nicht nach dem abschließenden PHP Tag in der letzten Zeile einfügen, sondern davor.

define(‚WP_MEMORY_LIMIT‘, ‚128M‘);

Durch diese Anweisung erhöhen wir das PHP Memory Limit auf 128 MB und lösen damit in einigen Fällen das Problem. Sollte es dennoch bestehen, kontaktieren du eventuell deinen Hoster, da er eventuell in einigen Fällen das Memory Limit auf andere Weise erhöhen, bzw. freigeben muss.

Deaktiviere Plugins / Themes

Sollte nach einer Plugin-Installation oder nach dem Aktualisieren von Plugins der sogenannte „White Screen of Death“ erscheinen, suchen du hier bitte nach dem Fehler. Falls du ein neues Plugin oder Theme installiert oder ein bestehendes aktualisiert haben, deaktivieren du dieses bitte wieder und überprüfen, ob der WordPress Fehler weiterhin die weiße Seite anzeigt.

Solltest du nicht wissen, welches Plugin Schuld ist, loggen du sich am besten per FTP ein und ändern den Namen des Plugin-Ordners vorübergehend ab. Hängen du einen weiteren Buchstaben an oder geben du ihm einen neuen Namen, sodass alle Plugins deaktiviert werden. Dadurch können du deinen Blog aufrufen und überprüfen, ob die Seite immer noch weiß ist.

Bedenken du bitte:

deine Plugin-Einstellungen bleiben erhalten und nachdem du dem Ordner seinen ursprünglichen Namen gegeben und die Plugins wieder aktiviert haben, ist alles wie zuvor. Sobald du herausgefunden haben, welches Plugin Schuld ist, löschen du es bitte.

Bitte laden du die neuen Core-Dateien von WordPress auf deinen Server.

Sollte die vorherige Behebung der WordPress Fehler nicht erfolgreich gewesen sein und dein Blog weiterhin eine weiße Seite anzeigen, müssen wir eine neue Maßnahme ergreifen. Laden du hier die neueste Version von WordPress herunter und entpacken du die .zip-Datei.

Als Nächstes laden du die wp-admin- und wp-includes-Ordner hoch und ersetzen damit die aktuellen. Danach machen du das Gleiche mit allen Dateien bis auf die wp-config.php und die .htaccess. Es kann helfen, den White Screen of Death zu bekämpfen.

WordPress verlangt auf einmal nach FTP Zugangsdaten

Praxis-Tipp für deinen Erfolg

Erfolgreiche digitale Strategien leben von kontinuierlicher Pflege und datenbasierter Optimierung. Teste neue Ansätze regelmäßig und behalte deine Kennzahlen im Blick.

Was versteht man darunter?

Manchmal kann es vorkommen, dass du bei der Installation oder dem Aktualisieren von Plugins und Themes von WordPress nach deinen FTP-Zugangsdaten gefragt werden. Das passiert, wenn der WordPress Fehler keinen Zugriff auf deine Dateien hat oder dein Apache-Benutzer über den falschen Modus läuft. Zwar klingt das kompliziert, aber es ist ganz einfach zu beheben.

Lösung des Problems

Um das Problem zu lösen, müssen du lediglich deine wp-config.php Datei öffnen und die drei folgenden Codezeilen hinzufügen, auf denen du deine FTP-Zugangsdaten hinterlegen.

define(‚FTP_HOST‘, ‚ftp.beispiel.de‘);
define(‚FTP_USER‘, ‚username‘);
define(‚FTP_PASS‘, ‚password‘);

Anschließend müssen du “ftp.beispiel.de”, “username” und “password” durch deine FTP-Daten ersetzen. Wenn du das getan haben, sollte die Abfrage deiner Daten nicht mehr erscheinen.

In einigen Fällen ist der Server auch nicht mehr bereit weitere Dateien hochzuladen bzw. zu aktualisieren, da der Platz meist nur begrenzt vorhanden ist. Es kann helfen, alte Dateien (Plugins, Bilder) vom Server zu löschen, damit das wieder funktioniert.

Nach dem Update: Wartungsseite

Was ist das für ein Problem?

Während der Installation von Plugins oder WordPress-Updates wird dein Blog vorübergehend offline sein und beim Aufrufen nur die Meldung „Aufgrund geplanter Wartungsarbeiten vorübergehend nicht verfügbar“ anzeigen. Normalerweise wird dieser Wartungsmodus nach Abschluss der Updates automatisch deaktiviert, manchmal jedoch bleibt er hängen und verschwindet nicht.

Wie kann man das beheben?

Zum Glück ist dieses WordPress Problem leicht zu beheben:

  1. Loggen du sich über FTP auf deinem Server ein
  2. navigieren du in das Hauptverzeichnis deiner WordPress-Installation
  3. löschen du die Datei „.maintenance„
  4. Prüfe, ob dein Blog wieder läuft, und starten du das Update erneut.

Eine 404-Fehlerseite erscheint

404 Page not found banner template
404 Page not found banner template

Worum handelt es sich?

Ein weithin bekannter WordPress Fehler ist, dass das Backend zwar erreicht wird, aber einige Seiten oder Beiträge, die aufgerufen werden, einen 404 Fehler auslösen und somit nicht verfügbar sind.
Dies kann daran liegen, dass die „.htaccess“ Datei gelöscht oder verändert wurde.
Keine Sorge, bei solchen Fällen werden keine Daten gelöscht und das Problem lässt sich mit kleinen Anpassungen beheben.

404 Seiten können zum Beispiel mithilfe von Plugins wie dem Broken Link Checker oder auch RankMath aufgespürt werden. Außerdem stellen SEO Tools wie PageRangers*, welches mein absolutes Lieblings-Tool ist, sie ebenfalls an. Hier können du mehr darüber lesen und herausfinden, ob es das richtige SEO Tool für dich ist.

Wie kann ich das Problem beheben?

Es gibt zwei Optionen, um die 404 Error Seiten zu lösen. Beginnen wir mit der unkompliziertesten Methode:

  1. Navigieren du in den Einstellungen zum „Permalinks“ Menü
  2. Klicken du unten auf den „Änderungen übernehmen“ Button, um WordPress dazu zu zwingen, die URLs neu zu generieren.
  3. Überprüfen du anschließend, ob die 404 Fehler immer noch existieren.

Falls ja, machen wir noch eine zweite Anpassung, um das Problem zu beheben:

Stelle über FTP eine Verbindung zu deinem Webserver her und öffnen du die „.htaccess“ Datei, die du im WordPress Hauptverzeichnis finden. Tragen du den folgenden Code in diese Datei ein. Solltest du die Datei nicht finden, müssen du selbst mit einem Texteditor eine solche Datei erstellen.

# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ – [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END

Fehler beim Upload? So beheben du ihn!

Was ist das bei vielen WordPress-Nutzern so bekannte typische Problem?

Es kommt vor allem nach dem Aktualisieren eines Plugins, Themas oder der Installation der neuesten WordPress-Version zum Vorschein: Beim Hochladen eines Bildes oder einer anderen Datei wird der Fehler “Beim Upload ist ein Fehler aufgetreten” angezeigt. Dieser Hinweis ist zwar nicht sehr hilfreich, dennoch gibt es verschiedene Ursachen dafür.

Wir werden nun Schritt für Schritt deren mögliche Lösungen durchgehen und den Fehler beheben. Anschließend sollte man überprüfen, ob das Problem immer noch besteht. Der Anfang wäre hier die Prüfung des verfügbaren Speicherplatzes beim Hoster, denn es kann ja sein, dass man das Limit erreicht hat.

Wie kann ich das Problem beheben?

Es gibt zwei Optionen, um den wordpress-fehler 404 Error zu lösen. Beginnen wir mit der unkompliziertesten Methode:

  1. Navigieren du in den Einstellungen zum „Permalinks“ Menü
  2. Klicken du unten auf den „Änderungen übernehmen“ Button, um WordPress dazu zu zwingen, die URLs neu zu generieren.
  3. Überprüfen du anschließend, ob die 404 Fehler immer noch existieren.

Falls ja, machen wir noch eine zweite Anpassung, um das Problem zu beheben:

Stelle über FTP eine Verbindung zu deinem Webserver her und öffnen du die „.htaccess“ Datei, die du im WordPress Hauptverzeichnis finden. Tragen du den folgenden Code in diese Datei ein. Solltest du die Datei nicht finden, müssen du selbst mit einem Texteditor (Word ist keiner!) eine solche Datei erstellen.

Auf die neueste PHP Version updaten

Um deine WordPress-Plattform, Plugins und Themes auf dem neusten Stand zu halten, ist es wichtig, dass du die PHP Version deiner Domain auf aktualisieren. Melden du sich bei deinem Hoster an und navigieren du zu dem Punkt „PHP-Versionen“ oder ähnliches. Obwohl die neuste Version viele Vorteile hat, können bestimmte Plugins und Themes möglicherweise nicht mit dieser Version kompatibel sein. Warten du also lieber damit, bis alle Apps damit funktionieren.

Memory Limit von PHP erhöhen

Wie schon bei dem “White Screen of Death” kann auch hier das PHP Memory Limit eine Rolle spielen. Navigiere also mithilfe deines FTP Programmes in das WordPress Hauptverzeichnis und füge in die wp-config.php den folgenden Code ein. Achte darauf, dass du diesen Code nicht nach dem schließenden PHP Tag in der aller letzten Zeile einfügen, sondern davor.

define(‚WP_MEMORY_LIMIT‘, ‚128M‘);

Dadurch wird das PHP Memory Limit auf 128 MB erhöht, was diesen Fehler oftmals behebt.

Deaktivieren du die Plugins

Hast du möglicherweise vor dem Auftreten des Fehlers ein neues Plugin installiert oder aktualisiert? Wenn ja, dann deaktiviere es wieder und überprüfe, ob der Fehler nach wie vor besteht. Hast du aber keine Installation oder Aktualisierung vorgenommen, so deaktiviere am besten einfach mal alle Plugins, um herauszufinden, ob eines davon den Fehler verursacht. Wenn der Upload nach dem Deaktivieren wieder funktioniert, aktiviere ein Plugin nach dem anderen erneut und überprüfe jeweils danach, ob der Upload immer noch funktioniert.

Berechtigungen deiner Ordner prüfen

du solltest einen Blick auf die Besitzrechte deiner WordPress Ordner werfen, da es möglicherweise nötig ist, diese zu ändern, um Dateien hochladen zu können. Um das zu erreichen, müssen du dein FTP Programm verwenden, um den Ordner „wp-content“ zu navigieren. Sobald du dort bist, können du mit einem Rechtsklick auf den Ordner „Uploads“ die Dateiberechtigungen auf 755 ändern und dabei sicherstellen, dass auch alle Unterordner diese Berechtigungen erhalten.

Nach dem Aktualisieren passiert nichts

Was ist das bei vielen WordPress-Nutzern so bekannte typische Problem?

Es kommt vor allem nach dem Aktualisieren eines Plugins, Themas oder der Installation der neuesten WordPress-Version zum Vorschein: Beim Hochladen eines Bildes oder einer anderen Datei wird der Fehler “Beim Upload ist ein Fehler aufgetreten” angezeigt. Dieser Hinweis ist zwar nicht sehr hilfreich, dennoch gibt es verschiedene Ursachen dafür.

Wir werden nun Schritt für Schritt deren mögliche Lösungen durchgehen und den Fehler beheben. Anschließend sollte man überprüfen, ob das Problem immer noch besteht. Der Anfang wäre hier die Prüfung des verfügbaren Speicherplatzes beim Hoster, denn es kann ja sein, dass man das Limit erreicht hat.

Was steckt dahinter?

Manchmal passiert es, dass sich auf einer vorhandenen Seite oder einem Artikel nicht nach den Änderungen und Aktualisierungen ändert. Das bedeutet, dass du den Inhalt einer bereits existierenden Seite ändern. Nach einem Klick auf „Aktualisieren“ lädt man die Seite erneut, aber die alten Inhalte werden immer noch angezeigt.

Dieses Problem wird durch das Caching verursacht, sei es durch den Browser Cache oder den Server Cache. Wie kann man es beheben?

Besuchen du die Plugin-Übersicht und deaktivieren du dein Caching-Plugin. In den meisten Fällen behebt das einfache Vergessen des Caches, ihn zu leeren und neu zu füllen, das Problem. Wenn die Seite dann mit den neuen Inhalten angezeigt wird, können du das Plugin wieder aktivieren und dadurch wird auch der Cache mit den neuen Inhalten gefüllt.

Falls auch das nicht hilft, rufen du deine Seite mit einem anderen Browser oder dem Smartphone auf, oder löschen du den Cache deines Browsers. Hier wird dann die Seite mit den neuen Inhalten angezeigt.

Auch schon oft vorgekommen, dass dein Router Daten im Cache speichert und die aktualisierten Inhalte nicht angezeigt werden. Da hilft folgendes: WLAN aus und über LTE neu laden.

Zu lange Anzeige der Beiträge in der Übersicht

Was ist dies?

Nachdem du die Homepage erstellen lassen, sehen du auf der Startseite oder einer anderen Seite möglicherweise eine Zusammenfassung deiner Blogartikel zur Verfügung, auch als deinen eigentlichen Blog. Wie die Artikel auf dieser Seite angezeigt werden, wird vom Theme deiner Seite bestimmt.

Je nach Theme kann es sein, dass der Beschreibungstext nach einer gewissen Wortanzahl abgeschnitten wird, gar nicht angezeigt wird oder der „Auszug“ des Beitrags genutzt wird. Es kommt aber auch vor, dass dort der gesamte Artikel angezeigt wird, ohne abgeschnitten zu werden. Das liegt an einem fehlenden „Weiterlesen-Tag“.

Wie können du dies beheben?

du kannst den “Weiterlesen-Tag” ganz leicht hinzufügen. Öffnen du dafür den Artikel im Backend und stellen du den Cursor an die Stelle, an der du den Artikel für die Übersichtsseite kürzen möchten (am besten hinter den ersten Abschnitt oder der Einleitung).

du navigieren mit der Maus in der Werkzeugleiste des WordPress Editors über das zweite Icon von rechts in der oberen Zeile (abhängig von Themes und Plugins können hier noch mehr Icons sein). Der Tooltip sagt dir jetzt “Weiterlesen-Tag einfügen” an. Klicken du auf dieses Icon, und im Editor wird eine gestrichelte Linie eingefügt, ab der der Artikel in der Übersichtsseite in Zukunft abgeschnitten wird. Im eigentlichen Artikel ist davon nichts zu sehen.

Benjamin Machalz
EXPERTE & AUTOR

Benjamin Machalz

Gründer und Inhaber von Hauptstadt Homepage in Berlin. Mit über 15 Jahren Praxis in moderner Webentwicklung, technischem SEO und Generative Engine Optimization unterstützt er mittelständische Unternehmen bei der nachhaltigen digitalen Transformation.